eve-ng搭建攻防域环境

0x00 搭建前准备:
扩容磁盘:
eve-ng搭建攻防域环境
把他扩容到想要的大小后
fdisk /dev/sda进入磁盘操作
eve-ng搭建攻防域环境
输入p显示分区表:
eve-ng搭建攻防域环境
输入n创建新分区,输入p创建主分区,输入3选择分区号
eve-ng搭建攻防域环境
添加后重启,然后将sda3扩容到卷组中
eve-ng搭建攻防域环境
eve-ng搭建攻防域环境
重新调整逻辑卷大小
eve-ng搭建攻防域环境
成功:
eve-ng搭建攻防域环境

导入思科路由器:
iol.rar上传到/opt/unetlab/addons/iol/bin下
运行CiscoIOUKeygen.py,把py生成的license替换进iourc:
eve-ng搭建攻防域环境
最后执行/opt/unetlab/wrappers/unl_wrapper -a fixpermissions
导入windows镜像:
因为eve只能导入qcow2格式的镜像,所以其他格式需要转换:
首先介绍不需要转换的方法:
将qcow2文件放入/opt/unetlab/addons/qemu下
然后运行命令/opt/unetlab/wrappers/unl_wrapper -a fixpermissions 修复权限
eve-ng搭建攻防域环境
若为img格式:
运行/opt/qemu/bin/qemu-img convert -f raw -O qcow2 windows.img hda.qcow2转换为qcow2格式
若为ova格式:
先解压:tar xvf windows.ova,得到vmdk文件
然后/opt/qemu/bin/qemu-img convert -f vmdk -O qcow2 windows.vmdk hda.qcow2转换
若为iso格式:
装入虚拟机,导出vmdk文件,接着和ova格式的操作一样
还可参考这两个官方文档的方法:
http://www.eve-ng.net/documentation/howto-s/104-how-to-create-own-windows-server-on-the-eve
http://www.eve-ng.net/documentation/howto-s/103-how-to-install-own-windows-host-on-the-eve

0x01网络配置
现在导入了win7、win2003、win2012、路由器4个元件,开始配置网络。
首先介绍一下eve-ng的网桥,右键network即可添加:
 Bridge:仅作用在EVE-NG 的Lab 内部,为节点对象互联互通,充当“傻瓜”交换机。
 Management (Cloud0):桥接到EVE-NG 的第1 块网卡中,即管理IP 桥接的网卡。
 Cloud1:桥接到EVE-NG 的第2 块网卡中。
 Cloud2:桥接到EVE-NG 的第3 块网卡中。
因为实验环境需要服务器反弹shell到vps上,所以配置management
拓扑图需要添加一个路由器(i86bi-linux-l3)、一个傻瓜交换机(i86bi-linux-l2)、一台pc和两台服务器:

eve-ng搭建攻防域环境

点击R1进入路由器操作页面:
因为e0/0接口连接到虚拟机的网卡上,ip是自动获取的,所以只需要配置nat就好。
具体命令:

enable //进入特权模式
conf t //进入配置模式
interface ethernet 0/1 //选择e0/1接口
no shutdown //开启接口
ip address 192.168.1.1 255.255.255.0 //配置ip
ip nat inside //配置nat
exit
ip dhcp pool lan //配置dhcp
default-router 192.168.1.1
dns-server 114.114.114.114
network 192.168.1.0 255.255.255.0
lease 2
exit
ip dhcp excluded-address 192.168.1.1 192.168.1.10
interface ethernet 0/0 //选择e0/0接口
ip nat outside //配置nat
exit
ip route 0.0.0.0 0.0.0.0 172.31.0.1 //配置缺省路由,最后一个ip需要指定management的网关
access-list 199 permit ip 192.168.1.0 0.0.0.255 any //配置动态nat
ip nat inside source list 199 interface ethernet 0/0 overload
end
write

配置好后,可以sh ip int brief 查看接口信息:
eve-ng搭建攻防域环境
启动windows server发现已经自动获取到了ip:
eve-ng搭建攻防域环境
ping一个网址,在路由器中可以看到nat转换过程:
eve-ng搭建攻防域环境
至此网络配置完成。

0x02 域环境搭建
将windws2012r2设置为DC:
配置一个静态ip,dns设置为静态ip后点击添加角色和功能
eve-ng搭建攻防域环境
选择安装AD域服务和DNS服务器:
eve-ng搭建攻防域环境
安好后点击右上角的黄色感叹号图标设置域服务:
eve-ng搭建攻防域环境
eve-ng搭建攻防域环境
全部默认下一步,开始安装:
eve-ng搭建攻防域环境
安好后重启即完成创建域控
eve-ng搭建攻防域环境
将win7加入testlab域:
先在AD控制器里添加一个用户:
eve-ng搭建攻防域环境
打开win7设置静态ip,dns指定域控ip
加入域:
eve-ng搭建攻防域环境
成功加入:
eve-ng搭建攻防域环境
win2003同理
eve-ng搭建攻防域环境
至此完成域环境的搭建,可以开始实验啦

0x03 小结
使用eve的过程填了不少坑,下面谈谈我的使用感受吧。最直观的感受就是方便,添加主机不需要再用克隆之类的功能等很久,可以直接右键添加,改变后的主机还可以打包成自定义镜像供以后使用。做好的环境可以导出工程随时备份。作为模拟软件来说,它的拟真效果说最强不为过,所有添加的节点都可以从物理机直接远程连接到,和实物操作没什么分别。而且网上有很多镜像,防火墙、vpn应有尽有,对于学习内网渗透的小伙伴来说是个神器了。

极牛网精选文章《eve-ng搭建攻防域环境》文中所述为作者独立观点,不代表极牛网立场。如若转载请注明出处:https://geeknb.com/13761.html

(32)
打赏 微信公众号 微信公众号 微信小程序 微信小程序
上一篇 2021年2月5日 下午1:18
下一篇 2021年2月6日 上午10:27

相关推荐

发表评论

登录后才能评论